Keep your homebrew up-to-date!
Stephen Starkey 8a97f5297d Trying a new kind of output 1 month ago
.gitignore First commit 1 month ago
LICENSE License 1 month ago
README.md License 1 month ago
brew-update-notifier Trying a new kind of output 1 month ago

README.md

brew-update-notifier

A simple script for detecting whether you have outdated homebrew packages and notifying you.

dependencies

When this project is done, the hope is you can just brew install this program. But for now, here are the dependencies you need to install before this program will work:

babashka, terminal-notifier

brew install borkdude/brew/babashka
brew install terminal-notifier

running

./brew-update-notifier

If everything is up-to-date, nothing will happen. If something went wrong, you will get notified using a standard Mac OS notification. The first time this happens you will likely be asked to give terminal-notifier permission to send a notification.

Another thing this program does is check to see if homebrew is still fine. Sometimes upgrades will cause homebrew to be broken in some way. If this happens, the script will notify you. It does this by executing brew doctor and testing to see if your system is ready to brew or not.

license

This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program.  If not, see <https://www.gnu.org/licenses/>.